MainTabsProps Interface
Properties for the base Tabs component
Extends
Inherited methods
Name |
Inherited from |
Description |
onActivateTab(index: number): any Optional |
TabsProps |
Handler for activating a tab |
Properties
Name |
Type |
Description |
|
mainClassName |
string |
Main CSS class name |
|
orientation |
Orientation |
Orientation of the Tabs list |
|
Inherited properties
Name |
Type |
Inherited from |
Description |
activeIndex |
undefined | number |
TabsProps |
Index of the initial active tab |
green |
undefined | boolean |
TabsProps |
Indicates whether the bar on the active tab is green instead of the default blue |
itemId |
undefined | string |
TabsProps |
Optional unique identifier for item. |
labels |
string | TabLabel[] |
TabsProps |
Text shown for each tab |
Defined in
Last Updated:
20 June, 2023