SettingsTabEntry Interface
Interface used to populate a tab entry in the SettingContainer control
Properties
Name | Type | Description | |
---|---|---|---|
icon Readonly | string | Element | Icon specification | |
isDisabled Readonly | boolean | ConditionalBooleanValue | Allows Settings entry to be disabled | |
itemPriority Readonly | number | used to determine position in tablist | |
label Readonly | string | localized display label | |
page Readonly | Element | Setting page content to display when tab item is selected. | |
pageWillHandleCloseRequest Readonly | undefined | boolean | Setting to true if page will register to watch for stage closing event so it can save any dirty settings. | |
subLabel Readonly | undefined | string | Optional Subtitle to show below label. | |
tabId Readonly | string | unique id for entry | |
tooltip Readonly | string | Element | Tooltip. |
Defined in
Last Updated: 20 June, 2023