RadioProps Interface
Deprecated in 3.0. Use RadioProps in itwinui-react instead
Properties for Radio component
Extends
- InputHTMLAttributes<HTMLInputElement>
- CommonProps
- LabeledComponentProps
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
inputClassName | undefined | string | LabeledComponentProps | Custom CSS class name for the checkbox input element |
inputStyle | undefined | CSSProperties | LabeledComponentProps | Custom CSS Style for the checkbox input element |
itemId | undefined | string | CommonProps | Optional unique identifier for item. |
label | undefined | string | LabeledComponentProps | Text that will be shown next to or above the input. |
labelClassName | undefined | string | LabeledComponentProps | Custom CSS class name for the label |
labelStyle | undefined | CSSProperties | LabeledComponentProps | Custom CSS Style for the label |
status | undefined | InputStatus | LabeledComponentProps | Input status like: "Success", "Warning" or "Error" |
Defined in
Last Updated: 20 June, 2023