InputLabelProps Interface
Properties for InputLabel components
Extends
Properties
Name | Type | Description | |
---|---|---|---|
disabled | undefined | boolean |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | undefined | string | CommonProps | Custom CSS class name |
inputClassName | undefined | string | LabeledComponentProps | Custom CSS class name for the checkbox input element |
inputStyle | undefined | CSSProperties | LabeledComponentProps | Custom CSS Style for the checkbox input element |
itemId | undefined | string | CommonProps | Optional unique identifier for item. |
label | undefined | string | LabeledComponentProps | Text that will be shown next to or above the input. |
labelClassName | undefined | string | LabeledComponentProps | Custom CSS class name for the label |
labelStyle | undefined | CSSProperties | LabeledComponentProps | Custom CSS Style for the label |
undefined | string | MessagedComponentProps | Optional text shown below the input. | |
undefined | string | MessagedComponentProps | Custom CSS class name for the message | |
undefined | CSSProperties | MessagedComponentProps | Custom CSS Style for the message | |
status | undefined | InputStatus | LabeledComponentProps | Input status like: "Success", "Warning" or "Error" |
style | undefined | CSSProperties | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 20 June, 2023