DialogProps Interface
Properties for the Dialog component
Extends
Methods
Name |
Description |
|
onClose(): void Optional |
onClick event for X button for dialog |
|
onEscape(): void Optional |
'keyup' event for Esc key |
|
onModelessPointerDown(event: PointerEvent<Element>, id: string): void Optional |
Pointer Down event handler when modeless (modal = false) |
|
onOutsideClick(event: MouseEvent): any Optional |
Triggered when a click is triggered outside of this dialog. |
|
Properties
Name |
Type |
Description |
|
alignment |
undefined | DialogAlignment |
Default alignment of dialog. |
|
backgroundStyle |
undefined | CSSProperties |
Custom CSS Style for overlay |
|
buttonCluster |
undefined | DialogButtonDef[] |
List of DialogButtonDef objects specifying buttons and associated onClick events |
|
contentClassName |
undefined | string |
Custom CSS class name for the content |
|
contentStyle |
undefined | CSSProperties |
Custom CSS Style for the content |
|
string | Element |
Footer to show at bottom of dialog. |
|
undefined | CSSProperties |
Custom CSS Style for footer |
|
undefined | ReactNode |
Override for the header |
|
height |
string | number |
Initial height of dialog. |
|
undefined | boolean |
Whether the hide the header. |
|
inset |
undefined | boolean |
Indicates whether the content should be inset. |
|
maxHeight |
string | number |
Maximum height that the dialog may be resized to. |
|
maxWidth |
string | number |
Maximum width that the dialog may be resized to. |
|
minHeight |
string | number |
Minimum height that the dialog may be resized to. |
|
minWidth |
string | number |
Minimum width that the dialog may be resized to. |
|
modal |
undefined | boolean |
Whether to show background overlay. |
|
modelessId |
undefined | string |
An id for a modeless dialog |
|
movable |
undefined | boolean |
Indicates whether the user can move dialog with cursor. |
|
opened |
boolean |
Indicates whether to show dialog or not |
|
resizable |
undefined | boolean |
Indicates whether the user can resize dialog with cursor. |
|
title |
string | Element |
Title to show in title bar of dialog |
|
titleStyle |
undefined | CSSProperties |
Custom CSS Style for title |
|
trapFocus |
undefined | boolean |
Indicates whether the focus should be trapped within the dialog. |
|
width |
string | number |
Initial width of dialog. |
|
x |
undefined | number |
Initial x/left position of dialog in px. |
|
y |
undefined | number |
Initial y/top position of dialog in px. |
|
Inherited properties
Name |
Type |
Inherited from |
Description |
itemId |
undefined | string |
CommonProps |
Optional unique identifier for item. |
Defined in
Last Updated:
20 June, 2023