GlobalContextMenuProps Interface
Properties for the GlobalContextMenu component
Extends
Inherited methods
Name | Inherited from | Description |
---|---|---|
onEsc(data: any): any Optional | ContextMenuProps | when Escape button is pressed |
onOutsideClick(event: MouseEvent): any Optional | ContextMenuProps | When click is registered outside of ContextMenu. |
onSelect(event: any): any Optional | ContextMenuProps | When list item or submenu is selected |
Properties
Name | Type | Description | |
---|---|---|---|
contextMenuComponent | undefined | ComponentType<ContextMenuProps> | Context menu element. | |
identifier | undefined | string | Unique identifier, to distinguish from other GlobalContextMenu components. | |
x | string | number | Specifies the x/horizontal position on the viewport. | |
y | string | number | Specifies the y/vertical position on the viewport. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
autoflip | undefined | boolean | ContextMenuProps | Whether menu flips directions based on screen edge. |
className | undefined | string | ContextMenuProps | Custom CSS class name |
direction | undefined | ContextMenuDirection | ContextMenuProps | Which direction the menu opens. |
edgeLimit | undefined | boolean | ContextMenuProps | Whether menu hugs screen edge when autoflip is off. |
floating | undefined | boolean | ContextMenuProps | whether menu floats on the viewport, or the page. |
hotkeySelect | undefined | boolean | ContextMenuProps | Whether Hotkey press selects item, or just highlights item. |
itemId | undefined | string | ContextMenuProps | Optional unique identifier for item. |
opened | boolean | ContextMenuProps | Whether ContextMenu is currently opened. |
selectedIndex | undefined | number | ContextMenuProps | starting menu item selected index Default: -1 |
style | undefined | CSSProperties | ContextMenuProps | Custom CSS style properties |
Defined in
Last Updated: 20 June, 2023