ContextMenuProps Interface
Properties for the ContextMenu component
Extends
Methods
Properties
Name | Type | Description | |
---|---|---|---|
autoflip | undefined | boolean | Whether menu flips directions based on screen edge. | |
direction | undefined | ContextMenuDirection | Which direction the menu opens. | |
edgeLimit | undefined | boolean | Whether menu hugs screen edge when autoflip is off. | |
floating | undefined | boolean | whether menu floats on the viewport, or the page. | |
hotkeySelect | undefined | boolean | Whether Hotkey press selects item, or just highlights item. | |
opened | boolean | Whether ContextMenu is currently opened. | |
selectedIndex | undefined | number | starting menu item selected index Default: -1 |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | undefined | string | CommonProps | Custom CSS class name |
itemId | undefined | string | CommonProps | Optional unique identifier for item. |
style | undefined | CSSProperties | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 20 June, 2023