Properties for the ContextMenuItem component
Extends
- Omit<React.AllHTMLAttributes<HTMLDivElement>, "disabled" | "hidden">
- CommonProps
Methods
Name |
Description |
|
onHotKeyParsed(hotKey: string): void Optional |
|
|
onHover(): any Optional |
|
|
onSelect(event: any): any Optional |
|
|
Properties
Name |
Type |
Description |
|
badgeType |
undefined | BadgeType |
Badge to be overlaid on the item. |
|
disabled |
boolean | ConditionalBooleanValue |
Disables any onSelect calls, hover/keyboard highlighting, and grays item. |
|
hidden |
boolean | ConditionalBooleanValue |
Indicates whether the item is visible or hidden. |
|
hideIconContainer |
undefined | boolean |
Hide the icon container. |
|
icon |
undefined | IconSpec |
Icon to display in the left margin. |
|
iconRight |
undefined | IconSpec |
Icon to display in the right margin. |
|
isSelected |
undefined | boolean |
|
|
Inherited properties
Name |
Type |
Inherited from |
Description |
itemId |
undefined | string |
CommonProps |
Optional unique identifier for item. |
Defined in
Last Updated:
20 June, 2023