constructor Method
Constructor
FormatterSpec(name: string, format: Format, conversions?: UnitConversionSpec[], persistenceUnit?: UnitProps): FormatterSpec
Parameter | Type | Description |
---|---|---|
name | string | The name of a format specification. |
format | Format | Defines the output format for the quantity value. |
conversions | UnitConversionSpec[] | An array of conversion factors necessary to convert from an input unit to the units specified in the format. |
persistenceUnit | UnitProps | The unit the magnitude value is input. |
Returns - FormatterSpec
Defined in
Last Updated: 20 June, 2023