UnitProps Interface
Beta
This interface provides basic information about a Unit that is return from a UnitProvider. This info uniquely identifies a unit by its name.
Implemented by
Properties
Name | Type | Description | |
---|---|---|---|
isValid Readonly | boolean | This is set to true if the Unit is known by the UnitsProvider. | |
label Readonly | string | Default label for unit. | |
name Readonly | string | Unique name for unit. | |
phenomenon Readonly | string | Unique name of unit phenomenon. | |
system Readonly | string | Unique system name. |
Defined in
- quantity/src/Interfaces.ts Line 20
Last Updated: 20 June, 2023