MobileDevice Class
Beta
Methods
Name | Description | |
---|---|---|
constructor(): MobileDevice | ||
authGetAccessToken(callback: (accessToken?: string, expirationDate?: string, err?: string) => void): void Abstract | ||
cancelDownloadTask(cancelId: number): boolean Abstract | ||
createDownloadTask(downloadUrl: string, isBackground: boolean, downloadTo: string, completion: MobileCompletionCallback, progress?: MobileProgressCallback): number Abstract | ||
emit(eventName: DeviceEvents, ...args: any[]): void | ||
getBatteryLevel(): number Abstract | ||
getBatteryState(): BatteryState Abstract | ||
getDownloadTasks(): DownloadTask[] Abstract | ||
getOrientation(): Orientation Abstract | ||
reconnect(connection: number): void Abstract | ||
resumeDownloadInBackground(requestId: number): boolean Abstract | ||
resumeDownloadInForeground(requestId: number): boolean Abstract |
Defined in
- mobile/src/backend/MobileHost.ts Line 44
Last Updated: 20 June, 2023