Handles Class
The set of ModifyHandles active. Only applies if there is a single element selected.
Methods
Name | Description | |
---|---|---|
constructor(ss: MarkupSelected, el: Element): Handles | ||
cancelDrag(): void | called when the reset button is pressed. | |
drag(ev: BeButtonEvent): void | ||
draw(): void | ||
endDrag(undo: UndoManager): EventHandled | complete the modification for the active handle. | |
npcToBox(p: Readonly<WritableXAndY>): Point2d | ||
npcToVb(p: Readonly<WritableXAndY>, result?: Point2d): Point2d | ||
npcToVbArray(pts: Point2d[]): Point2d[] | ||
remove(): void | ||
startDrag(ev: BeButtonEvent): EventHandled | ||
vbToBox(p: Readonly<WritableXAndY>, result?: Point2d): Point2d |
Properties
Name | Type | Description | |
---|---|---|---|
active | undefined | ModifyHandle | ||
dragging | boolean | ||
el | Element | ||
group | G | ||
handles Readonly | ModifyHandle[] | ||
npcToVbTrn | Transform | ||
ss | MarkupSelected | ||
vbToBoxTrn | Transform |
Defined in
- markup/src/SelectTool.ts Line 264
Last Updated: 20 June, 2023