triangulateSimplestSpaceLoop MethodStatic
- Emit triangles for a (possibly non-planar) loop for various simple cases:
- only 3 points: just emit that triangle.
- only 4 points: split across a diagonal, choosing the one with better aspect ratios of its two triangles.
- BUT
- do not complete the triangulation if perimeter is larger than maxPerimeter (i.e. only consider small areas)
- Hence it is expected that the caller will use this as the first attempt, possibly followed by calls to other more adventurous methods.
triangulateSimplestSpaceLoop(loop: Point3d[] | LineString3d, announceLoopAndTriangles: AnnounceLoopAndTrianglesFunction, maxPerimeter?: number): boolean
Parameter | Type | Description |
---|---|---|
loop | Point3d[] | LineString3d | |
announceLoopAndTriangles | AnnounceLoopAndTrianglesFunction | |
maxPerimeter | number |
Returns - boolean
Defined in
- topology/SpaceTriangulation.ts Line 131
Last Updated: 20 June, 2023