triangulateGreedyEarCut MethodStatic

"Triangulate" by cutting of the ear with best aspect ratio. Reject if successive normals have negative dot product with PolygonOps.AreaNormal

triangulateGreedyEarCut(points: Point3d[], announceLoopAndTriangles: AnnounceLoopAndTrianglesFunction): boolean

Parameter Type Description
points Point3d[]  
announceLoopAndTriangles AnnounceLoopAndTrianglesFunction  

Returns - boolean

Defined in

Last Updated: 20 June, 2023