spaceQuadDiagonalAspectRatio MethodStatic

  • Treat a space quad as two triangles with interior diagonal from point0 to point2
  • Return the smaller of the aspect ratios of the two triangles.
  • The quad edges proceed in the order [point0, point1, point2, point3]

spaceQuadDiagonalAspectRatio(point0: Point3d, point1: Point3d, point2: Point3d, point3: Point3d): number

Parameter Type Description
point0 Point3d first point of quad
point1 Point3d second point of quad (diagonally opposite of point3)
point2 Point3d third point (diagonally opposite point0)
point3 Point3d fourth point

Returns - number

Defined in

Last Updated: 20 June, 2023