IModelJson.ConeProps Interface
Interface for Cone value defined by centers, radii, and (optional) vectors for circular section planes.
- VectorX and vectorY are optional.
- If either one is missing, both vectors are constructed perpendicular to the vector from start to end.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
capped | undefined | boolean | flag for circular end caps. | |
end | XYZProps | Point on axis at end section | |
endRadius | undefined | number | radius at end section |
|
radius | undefined | number | single radius to be applied as both start and end | |
start | XYZProps | Point on axis at start section. | |
startRadius | undefined | number | radius at start section |
|
vectorX | undefined | XYZProps | optional x vector in start section. | |
vectorY | undefined | XYZProps | optional y vector in start section. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
xyVectors | undefined | [XYZProps, XYZProps] | IModelJson.AxesProps | Cartesian coordinate directions defined by X direction then Y direction. |
yawPitchRollAngles | undefined | YawPitchRollProps | IModelJson.AxesProps | See YawPitchAngles class for further information about using 3 rotations to specify orientation. |
zxVectors | undefined | [XYZProps, XYZProps] | IModelJson.AxesProps | Cartesian coordinate directions defined by Z direction then X direction. |
Defined in
- serialization/IModelJsonSchema.ts Line 240
Last Updated: 20 June, 2023