IModelJson.AxesProps Interface
- There are multiple ways to specify an orientation
- A "Best" among these is application specific.
- An object with AxesProps should only specify one of the variants.
- YawPitchRollAngles uses 3 angles.
- Cases where only one of the 3 is nonzero are intuitive
- Cases where more than one is nonzero have difficult interactions and order issues.
- xyVectors uses a vector along the x direction and a vector into positive xy plane along any direction not parallel to x.
- In most cases, users supply a normalized x and the actual normalized y vector.
- zxVectors uses a z vector and another vector into the positive zx plane.
- In most cases, users supply a normalized z and the actual normalized x vector.
Properties
Name | Type | Description | |
---|---|---|---|
xyVectors | undefined | [XYZProps, XYZProps] | Cartesian coordinate directions defined by X direction then Y direction. | |
yawPitchRollAngles | undefined | YawPitchRollProps | See YawPitchAngles class for further information about using 3 rotations to specify orientation. | |
zxVectors | undefined | [XYZProps, XYZProps] | Cartesian coordinate directions defined by Z direction then X direction. |
Defined in
- serialization/IModelJsonSchema.ts Line 193
Last Updated: 20 June, 2023