IModelJson.BoxProps Interface
Interface for Box (or frustum with all rectangular sections parallel to primary xy section).
- Orientation may be given in any
AxesProps
way (yawPitchRollAngles
,xyVectors
,zxVectors
). - If
topX
ortopY
are omitted, each defaults to itsbaseX
orbaseY
peer. - If
topOrigin
is given,height
is unused. - If
topOrigin
is omitted andheight
is given,topOrigin
is computed along the z axis at distanceheight
. - If both
topOrigin
andheight
are omitted,height
defaults tobaseX
, andtopOrigin
is computed as above.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
baseX | number | base x size (required) | |
baseY | undefined | number | base y size. | |
capped | undefined | boolean | optional capping flag. | |
height | undefined | number | optional height. | |
origin | XYZProps | Origin of the box coordinate system (required) | |
topOrigin | undefined | XYZProps | top origin. | |
topX | undefined | number | x size on top section. | |
topY | undefined | number | y size on top section. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
xyVectors | undefined | [XYZProps, XYZProps] | IModelJson.AxesProps | Cartesian coordinate directions defined by X direction then Y direction. |
yawPitchRollAngles | undefined | YawPitchRollProps | IModelJson.AxesProps | See YawPitchAngles class for further information about using 3 rotations to specify orientation. |
zxVectors | undefined | [XYZProps, XYZProps] | IModelJson.AxesProps | Cartesian coordinate directions defined by Z direction then X direction. |
Defined in
- serialization/IModelJsonSchema.ts Line 387
Last Updated: 20 June, 2023