createUniformKnots MethodStatic
Create a bspline with uniform knots.
- Control points may be supplied as:
- array of Point4d, with weight already multiplied into the
[wx,wy,wz,w]
- array of Point3d, with implied weight 1.
- Float64Array, blocked as xyzw, i.e. 4 doubles per control point.
- array of Point4d, with weight already multiplied into the
createUniformKnots(controlPoints: Point3d[] | Float64Array | Point4d[], order: number): undefined | BSplineCurve3dH
Parameter | Type | Description |
---|---|---|
controlPoints | Point3d[] | Float64Array | Point4d[] | pole data in array form as noted above. |
order | number | curve order (1 more than degree) |
Returns - undefined | BSplineCurve3dH
Defined in
- bspline/BSplineCurve3dH.ts Line 114
Last Updated: 20 June, 2023