create MethodStatic
Create a bspline with given knots.
The poles have several variants:
- Float64Array(4 * numPoles) in blocks of [wx,xy,wz,w]
- Point4d[numPoles]
- Point3d[], with implied unit weight to be added.
- {xyz: Float64Array(3 * numPoles), weights: Float64Array (numPoles)}
Two count conditions are recognized:
** If poleArray.length + order == knotArray.length, the first and last are assumed to be the extraneous knots of classic clamping. ** If poleArray.length + order == knotArray.length + 2, the knots are in modern form.
create(controlPointData: Point3d[] | Float64Array | Point4d[] | { weights: Float64Array, xyz: Float64Array }, knotArray: number[] | Float64Array, order: number): undefined | BSplineCurve3dH
Parameter | Type | Description |
---|---|---|
controlPointData | Point3d[] | Float64Array | Point4d[] | { weights: Float64Array, xyz: Float64Array } | |
knotArray | number[] | Float64Array | |
order | number |
Returns - undefined | BSplineCurve3dH
Defined in
- bspline/BSplineCurve3dH.ts Line 201
Last Updated: 20 June, 2023