SortableEdge Class
- For boundary sorting, an edge is a (packed!) Float64Array.
- Fixed entry positions are:
- [0] is start vertex index (in CCW order around its facet)
- [1] is end vertex index (in CCW order around its facet)
- [2] is facet index.
Extends
- Float64Array
Methods
Name | Description | |
---|---|---|
constructor(vertexA: number, vertexB: number, facetIndex: number): SortableEdge | ||
toJSON(): any | ||
areDirectedPartners(edgeA: SortableEdge, edgeB: SortableEdge): boolean Static | Return true if the vertices edgeA and edgeB are the same vertex indices in opposite order | |
areUndirectedPartners(edgeA: SortableEdge, edgeB: SortableEdge): boolean Static | Return true if the vertices edgeA and edgeB are the same vertex indices with no consideration of order | |
clusterArrayToJSON(data: SortableEdgeCluster[]): any[] Static | ||
clusterToJSON(data: SortableEdgeCluster): any Static | ||
lessThan(edgeA: SortableEdge, edgeB: SortableEdge): number Static | lexical comparison of two edges. | |
relativeOrientation(edgeA: SortableEdge, edgeB: SortableEdge): number Static | Return numeric relationship of edgeA and edgeB: |
Properties
Defined in
- polyface/IndexedEdgeMatcher.ts Line 17
Last Updated: 20 June, 2023