PolyfaceClip Class
PolyfaceClip is a static class gathering operations using Polyfaces and clippers.
Methods
Name | Description | |
---|---|---|
constructor(): PolyfaceClip | ||
clipPolyface(polyface: Polyface, clipper: ConvexClipPlaneSet | ClipPlane): undefined | Polyface Static | Clip each facet of polyface to the ClipPlane or ConvexClipPlaneSet | |
clipPolyfaceClipPlane(polyface: Polyface, clipper: ClipPlane, insideClip: boolean = true, buildClosureFaces: boolean = false): Polyface Static | Clip each facet of polyface to the ClipPlane. | |
clipPolyfaceClipPlaneWithClosureFace(polyface: Polyface, clipper: ClipPlane, insideClip: boolean = true, buildClosureFaces: boolean = true): Polyface Static | Clip each facet of polyface to the ClipPlane. | |
clipPolyfaceConvexClipPlaneSet(polyface: Polyface, clipper: ConvexClipPlaneSet): Polyface Static | Clip each facet of polyface to the ClipPlane. | |
clipPolyfaceInsideOutside(polyface: Polyface, clipper: ConvexClipPlaneSet | ClipPlane | UnionOfConvexClipPlaneSets, destination: ClippedPolyfaceBuilders, outputSelect: number = 0): void Static | Clip each facet of polyface to the ClipPlane or ConvexClipPlaneSet | |
clipPolyfaceUnderOverConvexPolyfaceIntoBuilders(visitorA: PolyfaceVisitor, visitorB: PolyfaceVisitor, builderAUnderB: undefined | PolyfaceBuilder, builderAOverB: undefined | PolyfaceBuilder): void Static | * Split facets of mesh "A" into parts that are | |
computeCutFill(meshA: IndexedPolyface, meshB: IndexedPolyface): { meshAOverB: IndexedPolyface, meshAUnderB: IndexedPolyface } Static | * Split facets into vertically overlapping sections | |
sectionPolyfaceClipPlane(polyface: Polyface, clipper: ClipPlane): LineString3d[] Static | Intersect each facet with the clip plane. |
Defined in
- polyface/PolyfaceClip.ts Line 92
Last Updated: 20 June, 2023