addUVGridBody Method
- Evaluate
(numU + 1) * (numV + 1)
grid points (in 0..1 in both u and v) on a surface. - Add the facets for
numU * numV
quads. - uv params are the 0..1 fractions.
- normals are cross products of u and v direction partial derivatives.
addUVGridBody(surface: UVSurface, numU: number, numV: number, uMap?: Segment1d, vMap?: Segment1d): void
Parameter | Type | Description |
---|---|---|
surface | UVSurface | |
numU | number | number of intervals (edges) in the u direction. (Number of points is numU + 1 ) |
numV | number | number of intervals (edges) in the v direction. (Number of points is numV + 1 ) |
uMap | Segment1d | optional mapping from u fraction to parameter space (such as texture) |
vMap | Segment1d | optional mapping from v fraction to parameter space (such as texture) |
Returns - void
Defined in
- polyface/PolyfaceBuilder.ts Line 1659
Last Updated: 20 June, 2023