addTriangleFan Method
Add triangles from points[0] to each far edge.
addTriangleFan(conePoint: Point3d, ls: LineString3d, toggle: boolean): void
Parameter | Type | Description |
---|---|---|
conePoint | Point3d | |
ls | LineString3d | linestring with point coordinates |
toggle | boolean | if true, wrap the triangle creation in toggleReversedFacetFlag. |
Returns - void
Defined in
- polyface/PolyfaceBuilder.ts Line 258
Last Updated: 20 June, 2023