addTriangleFacet Method
Add a triangle to the polyface given its points in order around the edges.
addTriangleFacet(points: Point3d[] | GrowableXYZArray, params?: Point2d[], normals?: Vector3d[], colors?: number[]): void
Parameter | Type | Description |
---|---|---|
points | Point3d[] | GrowableXYZArray | array of at least three vertices |
params | Point2d[] | optional array of at least three uv parameters (if undefined, params are calculated without reference data) |
normals | Vector3d[] | optional array of at least three vectors (if undefined, the normal is calculated) |
colors | number[] | optional array of at least three colors |
Returns - void
Defined in
- polyface/PolyfaceBuilder.ts Line 674
Last Updated: 20 June, 2023