addPolygon Method
Add a polygon to the evolving facets.
- Add points to the polyface
- indices are added (in reverse order if indicated by the builder state)
addPolygon(points: Point3d[], numPointsToUse?: number): void
Parameter | Type | Description |
---|---|---|
points | Point3d[] | array of points. This may contain extra points not to be used in the polygon |
numPointsToUse | number | number of points to use. |
Returns - void
Defined in
- polyface/PolyfaceBuilder.ts Line 1362
Last Updated: 20 June, 2023