addGreedyTriangulationBetweenLineStrings Method
Create (and add to the builder) triangles that bridge the gap between two linestrings.
- Each triangle will have 1 vertex on one of the linestrings and 2 on the other
- Choice of triangles is heuristic, hence does not have a unique solution.
- Logic to choice among the various possible triangle orders prefers
- Make near-coplanar facets
- make facets with good aspect ratio.
- This is exercised with a limited number of lookahead points, i.e. greedy to make first-available decision.
addGreedyTriangulationBetweenLineStrings(pointsA: Point3d[] | LineString3d | IndexedXYZCollection, pointsB: Point3d[] | LineString3d | IndexedXYZCollection): void
Parameter | Type | Description |
---|---|---|
pointsA | Point3d[] | LineString3d | IndexedXYZCollection | points of first linestring. |
pointsB | Point3d[] | LineString3d | IndexedXYZCollection | points of second linestring. |
Returns - void
Defined in
- polyface/PolyfaceBuilder.ts Line 1792
Last Updated: 20 June, 2023