addCoordinateFacets Method
Given arrays of coordinates for multiple facets.
- pointArray[i] is an array of 3 or 4 points
- paramArray[i] is an array of matching number of params
- normalArray[i] is an array of matching number of normals.
addCoordinateFacets(pointArray: Point3d[][], paramArray?: Point2d[][], normalArray?: Vector3d[][], endFace: boolean = false): void
Parameter | Type | Description |
---|---|---|
pointArray | Point3d[][] | array of arrays of point coordinates |
paramArray | Point2d[][] | array of arrays of uv parameters |
normalArray | Vector3d[][] | array of arrays of normals |
endFace | boolean | if true, call this.endFace after adding all the facets. |
Returns - void
Defined in
- polyface/PolyfaceBuilder.ts Line 1634
Last Updated: 20 June, 2023