StrokeCountChain Class
class StrokeCountChain
contains:
maps
= an array ofStrokeCountMap
parent
= parent CurveCollection.
An instance is normally created with either a Path
or Loop
as the parent.
Methods
Name | Description | |
---|---|---|
applySummed01Limits(incomingSum: number): number | walk the maps in the array. | |
getStrokes(): LineString3d | ||
createForCurveChain(chain: CurveChain, options?: StrokeOptions): StrokeCountChain Static |
Properties
Name | Type | Description | |
---|---|---|---|
maps | StrokeCountMap[] | ||
options | undefined | StrokeOptions | options are used (with different purposes) at two times: | |
parent | undefined | CurveCollection |
Defined in
- curve/Query/StrokeCountChain.ts Line 164
Last Updated: 20 June, 2023