RecursiveCurveProcessor Class
base class for detailed traversal of curve artifacts.
- This recurses to children in the quickest way (no records of path)
- Use the RecursiveCurveProcessorWithStack to record the path along the visit.
Extended by
Methods
Name | Description | |
---|---|---|
constructor(): RecursiveCurveProcessor Protected | ||
announceBagOfCurves(data: BagOfCurves, _indexInParent: number = -1): void | announce a bag of curves. | |
announceCurvePrimitive(_data: CurvePrimitive, _indexInParent: number = -1): void | process a leaf primitive. | |
announceLoop(data: Loop, _indexInParent: number = -1): void | announce a loop (recurse to children) | |
announceParityRegion(data: ParityRegion, _indexInParent: number = -1): void | announce beginning or end of loops in a parity region | |
announcePath(data: Path, _indexInParent: number = -1): void | announce a path (recurse to children) | |
announceUnexpected(_data: AnyCurve, _indexInParent: number): void | process error content | |
announceUnionRegion(data: UnionRegion, _indexInParent: number = -1): void | announce beginning or end of a parity region |
Defined in
- curve/CurveProcessor.ts Line 23
Last Updated: 20 June, 2023