LoopCurveLoopCurve Class
structure carrying a pair of loops with curve geometry.
Methods
Name | Description | |
---|---|---|
constructor(loopA: undefined | Loop, curveA: undefined | CurvePrimitive, loopB: undefined | Loop, curveB: undefined | CurvePrimitive): LoopCurveLoopCurve | ||
setA(loop: Loop, curve: CurvePrimitive): void | Set the loopA and curveA members | |
setB(loop: Loop, curve: CurvePrimitive): void | Set the loopB and curveB members |
Properties
Name | Type | Description | |
---|---|---|---|
curveA | undefined | CurvePrimitive | A curve (typically an edge of loopA) | |
curveB | undefined | CurvePrimitive | A curve (typically an edge of loopB) | |
loopA | undefined | Loop | First loop | |
loopB | undefined | Loop | second loop |
Defined in
- curve/Loop.ts Line 88
Last Updated: 20 June, 2023