createRegularPolygonXY MethodStatic
Create a regular polygon centered
createRegularPolygonXY(center: Point3d, edgeCount: number, radius: number, radiusToVertices: boolean = true): LineString3d
Parameter | Type | Description |
---|---|---|
center | Point3d | center of the polygon. |
edgeCount | number | number of edges. |
radius | number | distance to vertex or edge (see radiusToVertices ) |
radiusToVertices | boolean | true if polygon is inscribed in circle (radius measured to vertices); false if polygon is outside circle (radius to edges) |
Returns - LineString3d
Defined in
- curve/LineString3d.ts Line 391
Last Updated: 20 June, 2023