appendPlaneIntersectionPoints Method
find intersections with a plane. Intersections within segments are recorded as CurveIntervalRole.isolated Intersections at isolated "on" vertex are recoded as CurveIntervalRole.isolatedAtVertex.
appendPlaneIntersectionPoints(plane: PlaneAltitudeEvaluator, result: CurveLocationDetail[]): number
Parameter | Type | Description |
---|---|---|
plane | PlaneAltitudeEvaluator | |
result | CurveLocationDetail[] |
Returns - number
Defined in
- curve/LineString3d.ts Line 894
Last Updated: 20 June, 2023