closestPoint Method
Returns a curve location detail with both xyz and fractional coordinates of the closest point.
closestPoint(spacePoint: Point3d, extend: VariantCurveExtendParameter, result?: CurveLocationDetail): CurveLocationDetail
Parameter | Type | Description |
---|---|---|
spacePoint | Point3d | point in space |
extend | VariantCurveExtendParameter | if false, only return points within the bounded line segment. If true, allow the point to be on the unbounded line that contains the bounded segment. |
result | CurveLocationDetail |
Returns - CurveLocationDetail
Defined in
- curve/LineSegment3d.ts Line 178
Last Updated: 20 June, 2023