fractionToPointAndDerivative MethodAbstract
Return the point (x,y,z) and derivative on the curve at fractional position.
- Note that this derivative is "derivative of xyz with respect to fraction."
- this derivative shows the speed of the "fractional point" moving along the curve.
- this is not generally a unit vector. use fractionToPointAndUnitTangent for a unit vector.
fractionToPointAndDerivative(fraction: number, result?: Ray3d): Ray3d
Parameter | Type | Description |
---|---|---|
fraction | number | fractional position along the geometry. |
result | Ray3d |
Returns - Ray3d
Returns a ray whose origin is the curve point and direction is the derivative with respect to the fraction.
Defined in
- curve/CurvePrimitive.ts Line 125
Last Updated: 20 June, 2023