closestPoint Method
Search for the curve point that is closest to the spacePoint.
- If the space point is exactly on the curve, this is the reverse of fractionToPoint.
- Since CurvePrimitive should always have start and end available as candidate points, this method should always succeed
closestPoint(spacePoint: Point3d, extend: VariantCurveExtendParameter): undefined | CurveLocationDetail
Parameter | Type | Description |
---|---|---|
spacePoint | Point3d | point in space |
extend | VariantCurveExtendParameter | true to extend the curve (if possible), false for no extend, single CurveExtendOptions (for both directions), or array of distinct CurveExtendOptions for start and end. |
Returns - undefined | CurveLocationDetail
Returns a CurveLocationDetail structure that holds the details of the close point.
Defined in
- curve/CurvePrimitive.ts Line 498
Last Updated: 20 June, 2023