appendPlaneIntersectionPoints Method
Compute intersections with a plane.
- The intersections are appended to the result array.
- The base class implementation emits strokes to an AppendPlaneIntersectionStrokeHandler object, which uses a Newton iteration to get high-accuracy intersection points within strokes.
- Derived classes should override this default implementation if there are easy analytic solutions.
- Derived classes are free to implement extended intersections (e.g. arc!!!)
appendPlaneIntersectionPoints(plane: PlaneAltitudeEvaluator, result: CurveLocationDetail[]): number
Parameter | Type | Description |
---|---|---|
plane | PlaneAltitudeEvaluator | The plane to be intersected. |
result | CurveLocationDetail[] | Array to receive intersections |
Returns - number
Return the number of CurveLocationDetail's added to the result array.
Defined in
- curve/CurvePrimitive.ts Line 555
Last Updated: 20 June, 2023