updateIfCloserCurveFractionPointDistance Method
update or create if closer than current contents.
updateIfCloserCurveFractionPointDistance(curve: CurvePrimitive, fraction: number, point: Point3d, a: number): boolean
Parameter | Type | Description |
---|---|---|
curve | CurvePrimitive | candidate curve |
fraction | number | candidate fraction |
point | Point3d | candidate point |
a | number | candidate distance |
Returns - boolean
true if the given distance is smaller (and hence this detail was updated.)
Defined in
- curve/CurveLocationDetail.ts Line 367
Last Updated: 20 June, 2023