closestPoint Method
Search for the curve point that is closest to the spacePoint.
- The CurveChainWithDistanceIndex invokes the base class CurvePrimitive method, which (via a handler) determines a CurveLocation detail among the children.
- The returned detail directly identifies fractional position along the CurveChainWithDistanceIndex, and has pointer to an additional detail for the child curve.
closestPoint(spacePoint: Point3d, extend: VariantCurveExtendParameter): undefined | CurveLocationDetail
Parameter | Type | Description |
---|---|---|
spacePoint | Point3d | point in space |
extend | VariantCurveExtendParameter | true to extend the curve |
Returns - undefined | CurveLocationDetail
Returns a CurveLocationDetail structure that holds the details of the close point.
Defined in
- curve/CurveChainWithDistanceIndex.ts Line 680
Last Updated: 20 June, 2023