ArcVectors Interface
Compact vector form of an elliptic arc defined by center, vectors for angle coordinates 0 and 90 degrees, and sweep.
- See
Arc3d
for further details of the parameterization and meaning of the vectors.
Properties
Name | Type | Description | |
---|---|---|---|
center | Point3d | center point of arc. | |
sweep | AngleSweep | angle swept by the subset of the complete arc. | |
vector0 | Vector3d | vector to point at angle 0 in parameter space | |
vector90 | Vector3d | vector to point at angle 90 degrees in parameter space |
Defined in
- curve/Arc3d.ts Line 43
Last Updated: 20 June, 2023