set Method
Redefine the arc with (clones of) given data.
set(center: Point3d, matrix: Matrix3d, sweep: undefined | AngleSweep): void
Parameter | Type | Description |
---|---|---|
center | Point3d | arc center |
matrix | Matrix3d | matrix with columns vector0, vector 90, and their unit cross product |
sweep | undefined | AngleSweep | angle sweep |
Returns - void
Defined in
- curve/Arc3d.ts Line 152
Last Updated: 20 June, 2023