create MethodStatic
Create an arc by center with vectors to points at 0 and 90 degrees in parameter space.
create(center: undefined | Point3d, vector0: Vector3d, vector90: Vector3d, sweep?: AngleSweep, result?: Arc3d): Arc3d
Parameter | Type | Description |
---|---|---|
center | undefined | Point3d | arc center |
vector0 | Vector3d | vector to 0 degrees (commonly major axis) |
vector90 | Vector3d | vector to 90 degree point (commonly minor axis) |
sweep | AngleSweep | sweep limits |
result | Arc3d | optional preallocated result |
Returns - Arc3d
Defined in
- curve/Arc3d.ts Line 215
Last Updated: 20 June, 2023