createScaledXYColumns MethodStatic
Create an arc from center, x column to be scaled, and y column to be scaled.
createScaledXYColumns(center: undefined | Point3d, matrix: Matrix3d, radius0: number, radius90: number, sweep?: AngleSweep, result?: Arc3d): Arc3d
Parameter | Type | Description |
---|---|---|
center | undefined | Point3d | center of ellipse |
matrix | Matrix3d | matrix whose x and y columns are unit vectors to be scaled by radius0 and radius90 |
radius0 | number | radius in x direction. |
radius90 | number | radius in y direction. |
sweep | AngleSweep | sweep limits |
result | Arc3d | optional preallocated result. |
Returns - Arc3d
Defined in
- curve/Arc3d.ts Line 190
Last Updated: 20 June, 2023