createRefs MethodStatic
Create an arc, capturing references to center, matrix and sweep.
createRefs(center: Point3d, matrix: Matrix3d, sweep: AngleSweep, result?: Arc3d): Arc3d
Parameter | Type | Description |
---|---|---|
center | Point3d | center point |
matrix | Matrix3d | matrix with columns vector0, vector90, and unit cross product |
sweep | AngleSweep | sweep limits |
result | Arc3d | optional preallocated result. |
Returns - Arc3d
Defined in
- curve/Arc3d.ts Line 174
Last Updated: 20 June, 2023