allPerpendicularAngles Method
Return all angles (in radians) where the ellipse tangent is perpendicular to the vector to a spacePoint.
allPerpendicularAngles(spacePoint: Point3d, _extend: boolean = true, _endpoints: boolean = false): number[]
Parameter | Type | Description |
---|---|---|
spacePoint | Point3d | point of origin of vectors to the ellipse |
_extend | boolean | (NOT SUPPORTED -- ALWAYS ACTS AS "true") |
_endpoints | boolean | if true, force the end radians into the result. |
Returns - number[]
Defined in
- curve/Arc3d.ts Line 515
Last Updated: 20 June, 2023