Vector3dArray Class
The Vector3dArray
class contains static methods that act on arrays of 3d vectors.
Methods
Name | Description | |
---|---|---|
constructor(): Vector3dArray | ||
cloneVector3dArray(data: Readonly<WritableXYAndZ>[]): Vector3d[] Static | Return an array containing clones of the Vector3d data[] | |
isAlmostEqual(dataA: undefined | Vector3d[], dataB: undefined | Vector3d[]): boolean Static | Return true if arrays have same length and matching coordinates. |
Defined in
- geometry3d/PointHelpers.ts Line 276
Last Updated: 20 June, 2023