computePlanePlanePlaneIntersectionsInAllConvexSets Method
Collect the output from computePlanePlanePlaneIntersections in all the contained convex sets.
computePlanePlanePlaneIntersectionsInAllConvexSets(points: undefined | Point3d[], rangeToExtend: undefined | Range3d, transform?: Transform, testContainment: boolean = true): number
Parameter | Type | Description |
---|---|---|
points | undefined | Point3d[] | (optional) array to which computed points are to be added. |
rangeToExtend | undefined | Range3d | |
transform | Transform | (optional) transform to apply to the points. |
testContainment | boolean | if true, test each point to see if it is within the convex set. (Send false if confident that the convex set is rectilinear set such as a slab. Send true if chiseled corners are possible) |
Returns - number
number of points.
Defined in
Last Updated: 20 June, 2023