announceClippedSegmentIntervals Method
- announce clipSegment() for each convexSet in this ClipPlaneSet.
- all clipPlaneSets are inspected
- announced intervals are for each individual clipPlaneSet -- adjacent intervals are not consolidated.
announceClippedSegmentIntervals(f0: number, f1: number, pointA: Point3d, pointB: Point3d, announce?: (fraction0: number, fraction1: number) => void): boolean
Parameter | Type | Description |
---|---|---|
f0 | number | active interval start. |
f1 | number | active interval end |
pointA | Point3d | line segment start |
pointB | Point3d | line segment end |
announce | (fraction0: number, fraction1: number) => void | function to announce interval. |
Returns - boolean
Return true if any announcements are made.
Defined in
Last Updated: 20 June, 2023