createMatrixPickupPutdown MethodStatic
Create a transform with the specified matrix, acting on any pointX
via
pointY = matrix * (pointX - pointA) + pointB
so that the fixedPoint maps back to itself.
createMatrixPickupPutdown(matrix: Matrix3d, pointA: Point3d, pointB: Point3d, result?: Transform): Transform
Parameter | Type | Description |
---|---|---|
matrix | Matrix3d | |
pointA | Point3d | |
pointB | Point3d | |
result | Transform |
Returns - Transform
Defined in
- geometry3d/Transform.ts Line 290
Last Updated: 20 June, 2023