intersectionWithPlane Method
Return the intersection of the unbounded ray with a plane. Stores the point of intersection in the result point given as a parameter, and returns the parameter along the ray where the intersection occurs. Returns undefined if the ray and plane are parallel or coplanar.
intersectionWithPlane(plane: Plane3dByOriginAndUnitNormal, result?: Point3d): undefined | number
Parameter | Type | Description |
---|---|---|
plane | Plane3dByOriginAndUnitNormal | |
result | Point3d |
Returns - undefined | number
Defined in
- geometry3d/Ray3d.ts Line 262
Last Updated: 20 June, 2023